This project is read-only.

Error after 1st time login as Admin

Topics: User Forum
Aug 13, 2006 at 6:55 AM
Installer.aspx ran fine and Admin account is in the db.
Running in a virtual directory under a SharePoint Server 2007 virtual server (with Ttrust = Full).

Object reference not set to an instance of an object.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

Source Error:


Line 63: foreach (SiteMapNode child in root.ChildNodes)
Line 64: {
Line 65: if (child.ChildNodes.Count > 0 && child"showAsTab".ToLower() == "true")
Line 66: {
Line 67: IList roles = child.Roles;


Source File: c:\Inetpub\SQLWebTools\Controls\TabStripControl.ascx.cs Line: 65

Stack Trace:


NullReferenceException: Object reference not set to an instance of an object.
TabStripControl.Page_Load(Object sender, EventArgs e) in c:\Inetpub\SQLWebTools\Controls\TabStripControl.ascx.cs:65
System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +15
System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) +34
System.Web.UI.Control.OnLoad(EventArgs e) +99
System.Web.UI.Control.LoadRecursive() +47
System.Web.UI.Control.LoadRecursive() +131
System.Web.UI.Control.LoadRecursive() +131
System.Web.UI.Control.LoadRecursive() +131
System.Web.UI.Control.LoadRecursive() +131
System.Web.UI.Control.LoadRecursive() +131
System.Web.UI.Control.LoadRecursive() +131
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +1061




--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:2.0.50727.42; ASP.NET Version:2.0.50727.42
Aug 24, 2006 at 5:54 AM
It looks like this call is failing:

child"showAsTab".ToLower()

The reason you would get a null exception is if child didn't have a "showAsTab" attribute.

Double-check your sitemap and be sure that you add the attribute "showAsTab" to all your sitemap nodes.